v37.0.0 – Switch from PHP 5.6 to 7.1

October 9, 2018

Summary

The release of Qobrix v37.0.0 drops all support for PHP 5 and switches to PHP 7.

Overview

Switch from PHP 5.6 to 7.1

Since the early days, Qobrix has been developed, tested, and deployed on the PHP 5 environments.  Until today, we have supported PHP 5.6, even though it has reached the end of life (active support) on January 19, 2017. By the end of this year, PHP 5.6 will stop receiving even the security updates.

For a long time now, Qobrix worked just fine on PHP 7 environments and testing of PHP 7.0, 7.1, and 7.2 has been a part of our quality assurance.  In fact, we have been deploying Qobrix almost exclusively to the PHP 7.1 environments for a few months now.

Maintaining the support for both PHP 5 and PHP 7 is not an easy job.  It requires quite a bit of the compatibility code, compromises on the libraries and tools, and significantly slows down the development pace.  So today we are dropping all support for the PHP 5 and focusing exclusively on PHP 7.

Since PHP 7.0 has also reached its end of life, we decided to drop the support for it as well.  The minimum required version for any Qobrix application now is PHP 7.1.  We also have PHP 7.2 and nightly releases as part of our quality assurance.  This will make upgrading to newer PHP versions a lot easier in the future.

Good bye PHP 5!  You’ve been good to us and we had a lot of fun.  Hello PHP 7!  We hope the fun will continue and we’ll spend a few years together.

 

Component Updates